”home” key on the PS/2 keyboard triggers sleep mode in Precise after installing linux-generic-lts-trusty

20. toukokuuta 2014 klo 15.35
Sijainti: Vianhallintajärjestelmät: Launchpad
Avainsanat: Compaq, HP, Linux

I have a HP/Compaq SDM4700P PS/2 keyboard, quite a prevalent model (I even have two myself). The keyboard has a set of 8 ”internet” keys on the top, one of which has a ”home” icon (so it’s supposed to be XF86HomePage I believe).

After installing linux-generic-lts-trusty (3.13.0-27.23 from -proposed), pressing the ”home” key triggers the computer going to sleep (powering down, power led starts blinking).

This did not happen with kernels prior to 3.13.

I installed and booted 3.13.0-24.47 (also available in the repositories now) and the issue was still reproducible.

To be sure, I also tried 3.11.0-22.38 and 3.8.0-41.60 again, and it was *not* reproducible.

(I wouldn’t have much use for the ”home” key as such, but as the keyboard lacks audio controls, I’ve remapped the ”home” key to be my XFAudioMute with ~/.Xmodmap. This was working fine until 3.13; now it still does mute the audio just before putting the computer to sleep. As I don’t use sleep mode otherwise, I’ve worked around this by adding an `exit` at the top of /etc/acpi/sleep.sh.)

Vastaa viestiin sen kontekstissa (Launchpad)